Slow Response Time
Incident Report for Chalkup
Resolved
All systems are back to normal. Thank you for your patience!
Posted 11 months ago. Nov 14, 2016 - 11:41 EST
Investigating
We are investigating reports of slow loading time across Chalkup.
Posted 11 months ago. Nov 14, 2016 - 11:27 EST