Google Login Not Working
Incident Report for Chalkup
Resolved
Looks like everything's back to normal with Google Login.
Posted over 1 year ago. Apr 19, 2016 - 10:33 EDT
Investigating
There seems to be an issue with Google login right now - unfortunately we're waiting on Google to see what's up! We'll keep you posted.
Posted over 1 year ago. Apr 19, 2016 - 10:20 EDT